Vulnerabilities / Greenshift / WPSEC-2026-2614

Greenshift <= 13.2.2 - Unauthenticated DOM-Based Cross-Site Scripting via Interaction Layer Placeholders

Medium 4.7 CWE-79Fixed in 13.2.3
ID
WPSEC-2026-2614
Plugin
Greenshift – animation and page builder blocks (greenshift-animation-and-page-builder-blocks)
Affected
all versions before 13.2.3
Remediation
Update to 13.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
Greenshift on WPSec AttackSurface
Fix released
Published

Description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to DOM-Based Cross-Site Scripting via Interaction Layer placeholders in all versions up to, and including, 13.2.2, due to {{VALUE}}, {{ATTR:...}}, {{STORAGE:...}} and {{COOKIE:...}} values being written unescaped into innerHTML by the Set HTML content action, and into event handler, srcdoc or javascript: URL attributes by the Attach attribute action. On sites with an Interaction Layer that reads such data, this makes it possible for unauthenticated attackers who can control the data (for example an attribute of a comment they submit) to inject arbitrary web scripts that execute when a visitor triggers the interaction.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0