Vulnerabilities / WS Form LITE / WPSEC-2026-2624

WS Form LITE <= 1.12.18 - Unauthenticated Stored Cross-Site Scripting via Nested Form Field Values

High 7.2 CWE-79Fixed in 1.12.19
ID
WPSEC-2026-2624
Plugin
WS Form LITE – Drag & Drop Contact Form Builder (ws-form)
Affected
all versions before 1.12.19
Remediation
Update to 1.12.19 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
Attack surface
WS Form LITE on WPSec AttackSurface
Fix released
Published

Description

The WS Form LITE plugin for WordPress is vulnerable to Stored Cross-Site Scripting via submitted form field values in all versions up to, and including, 1.12.18. This is due to insufficient input sanitization and output escaping: nested arrays or objects posted as field values were stored as-is, and the client-side esc_html function returned non-string values without encoding them. This makes it possible for unauthenticated attackers to submit a form with crafted nested values and inject arbitrary web scripts that execute when a user, such as an administrator viewing form submissions, accesses a page rendering those values.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0