Rate Star Review Vote <= 1.6.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'id' Shortcode Attribute
- ID
- WPSEC-2026-2625
- Plugin
- Rate Star Review Vote – AJAX Reviews, Votes, Star Ratings (rate-star-review)
- Affected
- from 1.5.2 before 1.6.10
- Remediation
- Update to 1.6.10 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
- Attack surface
- Rate Star Review Vote on WPSec AttackSurface
- Fix released
- Published
Description
The Rate Star Review Vote plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' attribute of the videowhisper_reviews shortcode in all versions up to, and including, 1.6.5 due to insufficient input sanitization of the attribute before it is concatenated into inline JavaScript function and variable names. esc_js() does not neutralize characters such as parentheses and semicolons in that identifier context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2625/
- https://plugins.svn.wordpress.org/rate-star-review/tags/1.6.10/
- https://wordpress.org/plugins/rate-star-review/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS