Vulnerabilities / GTM4WP / WPSEC-2026-2634

GTM4WP <= 2.0.6 - Unauthenticated Sensitive Information Exposure via Cached WooCommerce Reliable Purchase Tracking Pages

Low 3.7 CWE-524Fixed in 2.1.0
ID
WPSEC-2026-2634
Plugin
GTM4WP – A Google Tag Manager (GTM) plugin for WordPress (duracelltomi-google-tag-manager)
Affected
from 2.0.0 before 2.1.0
Remediation
Update to 2.1.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-524
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-06
Attack surface
GTM4WP on WPSec AttackSurface
Fix released
Published

Description

The GTM4WP – A Google Tag Manager (GTM) plugin for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure via the WooCommerce Reliable Purchase Tracking feature in all versions from 2.0.0 up to, and including, 2.0.6, due to the plugin writing a shopper's pending purchase into the data layer of whatever page that shopper views next without marking the page as uncacheable. The data can include the purchase event, the raw order data with the buyer's name, addresses, email and phone, and the Enhanced Conversions user data. This makes it possible for unauthenticated attackers to view another shopper's order and customer details when a page cache stores and serves such a page. Exploitation requires Reliable Purchase Tracking to be enabled (it is off by default), the cache-safe data layer to be off, and a page cache that stores pages for visitors with a WooCommerce session.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0