Vulnerabilities / Bit Form / WPSEC-2026-2655
Bit Form <= 3.4.0 - Unauthenticated Stored Cross-Site Scripting via URL Field
Medium 6.1
CWE-79Fixed in 3.5.0
- ID
- WPSEC-2026-2655
- Plugin
- Bit Form – Contact Form, Payment Forms, Multi Step Forms, Calculator & Custom Form Builder (bit-form)
- Affected
- all versions before 3.5.0
- Remediation
- Update to 3.5.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
- Attack surface
- Bit Form on WPSec AttackSurface
- Fix released
- Published
Description
The Bit Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via URL field submissions in all versions up to, and including, 3.4.0. The cause is insufficient validation of URL schemes, which allowed javascript:, data: and vbscript: links to be stored and rendered as links on entry screens. This makes it possible for unauthenticated attackers to inject arbitrary scripts that execute when an administrator viewing the entry clicks the injected link.
References
- https://wpsec.com/vuln/WPSEC-2026-2655/
- https://plugins.svn.wordpress.org/bit-form/tags/3.5.0/
- https://wordpress.org/plugins/bit-form/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS