Vulnerabilities / ActivityPub / WPSEC-2026-2666

ActivityPub <= 9.4.2 - Unauthenticated Stored Cross-Site Scripting via Custom Emoji Tag Name

High 7.2 CWE-79Fixed in 9.4.3
ID
WPSEC-2026-2666
Plugin
ActivityPub (activitypub)
Affected
all versions before 9.4.3
Remediation
Update to 9.4.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
Attack surface
ActivityPub on WPSec AttackSurface
Fix released
Published

Description

The ActivityPub plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name' of custom Emoji tags in federated replies and remote posts in all versions up to, and including, 9.4.2. This is due to insufficient validation of the remote-controlled emoji name. After the remote HTML has been sanitized, every case-insensitive occurrence of the name in the content is replaced with activitypub/emoji block delimiters. When a name matches part of the sanitized markup, such as text inside an attribute value, these delimiters land inside HTML tags and attributes, and the block renderer later rebuilds the markup into unsafe HTML. This makes it possible for unauthenticated attackers operating a remote Fediverse account to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page, including the comment moderation screen.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0