Vulnerabilities / The GDPR Framework By Data443 / WPSEC-2026-2674
The GDPR Framework By Data443 <= 2.5.1 - Authenticated (Contributor+) Missing Authorization to Sensitive Information Exposure via Do Not Sell Requests
Medium 4.3
CWE-862Fixed in 2.5.2
- ID
- WPSEC-2026-2674
- Plugin
- The GDPR Framework By Data443 (gdpr-framework)
- Affected
- from 1.0.40 before 2.5.2
- Remediation
- Update to 2.5.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
- Attack surface
- The GDPR Framework By Data443 on WPSec AttackSurface
- Fix released
- Published
Description
The The GDPR Framework By Data443 plugin for WordPress is vulnerable to unauthorized access to CCPA 'Do Not Sell' requests in all versions up to, and including, 2.5.1. This is due to the 'donotsellrequests' custom post type being registered with the default post capabilities instead of the plugin's administrative capability. This makes it possible for authenticated attackers, with Contributor-level access and above, to list Do Not Sell requests containing requester names and email addresses, and for users with Editor-level access to edit or delete those requests.
References
- https://wpsec.com/vuln/WPSEC-2026-2674/
- https://plugins.svn.wordpress.org/gdpr-framework/tags/2.5.2/
- https://wordpress.org/plugins/gdpr-framework/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS