Everest Forms <= 3.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Form Custom JavaScript
- ID
- WPSEC-2026-2675
- Plugin
- Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder with AI (everest-forms)
- Affected
- from 2.0.2 before 3.6.4
- Remediation
- Update to 3.6.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-06
- Attack surface
- Everest Forms on WPSec AttackSurface
- Fix released
- Published
Description
The Everest Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form custom JavaScript setting in all versions up to, and including, 3.6.3. This is due to the 'everest_form' post type using the generic 'post' capability type, so any user with edit_posts can create form posts with arbitrary form settings in their content, and the custom JavaScript of any form, including draft forms, being output unescaped when the form is embedded with the [everest_form] shortcode, without checking whether the form's author had the unfiltered_html capability. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the form.
References
- https://wpsec.com/vuln/WPSEC-2026-2675/
- https://plugins.svn.wordpress.org/everest-forms/tags/3.6.4/
- https://wordpress.org/plugins/everest-forms/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS