Vulnerabilities / AMP for WP / WPSEC-2026-2691

AMP for WP <= 1.1.19 - Unauthenticated Stored Cross-Site Scripting via AMP Content Filter Attribute-Boundary Shift

High 7.2 CWE-79Fixed in 1.1.20
ID
WPSEC-2026-2691
Plugin
AMP for WP – Accelerated Mobile Pages (accelerated-mobile-pages)
Affected
from 0.9.33 before 1.1.20
Remediation
Update to 1.1.20 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
AMP for WP on WPSec AttackSurface
Fix released
Published

Description

The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the AMP output buffer filter (ampforwp_the_content_filter_full) in all versions up to, and including, 1.1.19, due to quote-unaware regular-expression rewriting of the fully rendered AMP page. The filter removes 'onclick=' sequences up to the next '>' and '<g...>' sequences, among others. When that text appears inside an attribute value that passed kses filtering, such as the title of a link in a comment, the closing quote is removed and the text that follows becomes live attributes. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected AMP page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0