Vulnerabilities / Pay by paynow.pl / WPSEC-2026-2700

Pay by paynow.pl <= 2.5.12 - Unauthenticated Sensitive Information Exposure via Cached Payment Methods

Low 3.7 CWE-524Fixed in 2.5.13
ID
WPSEC-2026-2700
Plugin
Pay by paynow.pl (pay-by-paynow-pl)
Affected
all versions before 2.5.13
Remediation
Update to 2.5.13 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-524
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
Pay by paynow.pl on WPSec AttackSurface
Fix released
Published

Description

The Pay by paynow.pl plugin for WordPress is vulnerable to Sensitive Information Exposure via the cached checkout payment methods in all versions up to, and including, 2.5.12, due to the payment methods list returned by Paynow being stored in a site-wide transient keyed only by the signature key, currency and amount. That list can include a logged-in customer's saved card instruments, and the key does not include the current user. This makes it possible for unauthenticated attackers who open checkout with the same currency and cart amount while the cached entry is valid (up to 24 hours) to view another customer's saved card details (card name, brand, expiry date and instrument token).

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0