Vulnerabilities / Live Composer / WPSEC-2026-2703

Live Composer <= 2.1.23 - Authenticated (Contributor+) Stored Cross-Site Scripting via Staff and Staff Social Modules

Medium 6.4 CWE-79Fixed in 2.1.24
ID
WPSEC-2026-2703
Plugin
Live Composer – Free WordPress Website Builder (live-composer-page-builder)
Affected
all versions before 2.1.24
Remediation
Update to 2.1.24 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
Live Composer on WPSec AttackSurface
Fix released
Published

Description

The Live Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Staff and Staff Social modules in all versions up to, and including, 2.1.23, due to insufficient output escaping of the heading titles, the view-all link, filter names, CSS class and carousel data attributes, the staff position and the staff social link URLs and link target. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0