Vulnerabilities / WP ImageViewer / WPSEC-2026-2728

WP ImageViewer <= 3.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Alt Text

Medium 6.4 CWE-79Fixed in 3.0.3
ID
WPSEC-2026-2728
Plugin
WP ImageViewer (wp-imageviewer)
Affected
all versions before 3.0.3
Remediation
Update to 3.0.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
WP ImageViewer on WPSec AttackSurface
Fix released
Published

Description

The WP ImageViewer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via image alt text in all versions up to, and including, 3.0.2. This is due to the viewer's front-end JavaScript reading an image's alt attribute, which the browser has already entity-decoded, and writing it into the viewer's description with innerHTML instead of inserting it as text. This makes it possible for authenticated attackers, with contributor-level access and above, to put an image linked to an image file in a post with an alt attribute holding entity-encoded HTML. That markup survives content filtering and injects arbitrary web scripts that execute in a user's browser when the image is opened in the viewer.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0