Vulnerabilities / WP Directory Kit / WPSEC-2026-2729

WP Directory Kit <= 1.5.9 - Unauthenticated Sensitive Information Exposure via Front-End AJAX Select, Treefield and Results Endpoints

Medium 5.3 CWE-200Fixed in 1.6.1
ID
WPSEC-2026-2729
Plugin
WP Directory Kit (wpdirectorykit)
Affected
all versions before 1.6.1
Remediation
Update to 1.6.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-08
Attack surface
WP Directory Kit on WPSec AttackSurface
Fix released
Published

Description

The WP Directory Kit plugin for WordPress is vulnerable to Sensitive Information Exposure via its select_2_ajax, treefield and results/map front-end AJAX functions in all versions up to, and including, 1.5.9. This is due to these functions returning the columns named in the request, accepting any model name, and returning unpublished listings. This makes it possible for unauthenticated attackers to extract data from listings that should not be public and from other plugin tables.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0