Vulnerabilities / Co-Authors Plus / WPSEC-2026-2743

Co-Authors Plus <= 4.2.1 - Unauthenticated Sensitive Information Exposure via Author Private Post Counts

Medium 5.3 CWE-200Fixed in 4.2.2
ID
WPSEC-2026-2743
Plugin
Co-Authors Plus (co-authors-plus)
Affected
all versions before 4.2.2
Remediation
Update to 4.2.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-08
Attack surface
Co-Authors Plus on WPSec AttackSurface
Fix released
Published

Description

The Co-Authors Plus plugin for WordPress is vulnerable to Sensitive Information Exposure via the count_user_posts() filter in all versions up to, and including, 4.2.1, due to author post counts including private posts whoever is viewing. Core's REST API users route lets anyone read a user who has a non-zero post count. This makes it possible for unauthenticated attackers to read the profiles of users who only have private posts, and to learn that those private posts exist.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0