Vulnerabilities / Co-Authors Plus / WPSEC-2026-2745
Co-Authors Plus <= 4.2.1 - Authenticated (Contributor+) Sensitive Information Exposure via Posts List Co-Authors Column
Medium 4.3
CWE-200Fixed in 4.2.2
- ID
- WPSEC-2026-2745
- Plugin
- Co-Authors Plus (co-authors-plus)
- Affected
- all versions before 4.2.2
- Remediation
- Update to 4.2.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-08
- Attack surface
- Co-Authors Plus on WPSec AttackSurface
- Fix released
- Published
Description
The Co-Authors Plus plugin for WordPress is vulnerable to Sensitive Information Exposure via the co-authors column of the admin posts list in all versions up to, and including, 4.2.1, due to the column printing each co-author's email address and login in data attributes for every user who can view the list, not only for users who can set authors. This makes it possible for authenticated attackers with Contributor-level access and above to obtain the email addresses and usernames of other authors and guest authors.
References
- https://wpsec.com/vuln/WPSEC-2026-2745/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.2/
- https://wordpress.org/plugins/co-authors-plus/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS