Vulnerabilities / Download Manager / WPSEC-2026-2748

Download Manager <= 3.3.75 - Authenticated (Contributor+) Sensitive Information Exposure via [wpdm_all_packages] Shortcode 'cols' Attribute

Medium 4.3 CWE-200Fixed in 3.3.76
ID
WPSEC-2026-2748
Plugin
Download Manager (download-manager)
Affected
all versions before 3.3.76
Remediation
Update to 3.3.76 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-08
Attack surface
Download Manager on WPSec AttackSurface
Fix released
Published

Description

The Download Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the [wpdm_all_packages] shortcode in all versions up to, and including, 3.3.75. This is due to the raw post row, including the post password, being merged into the column data, while the 'cols' attribute can print any key of that data. This makes it possible for authenticated attackers with contributor-level access or above to embed the shortcode with cols="post_password" and read the passwords protecting other users' packages.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0