Vulnerabilities / Academy LMS / WPSEC-2026-1671
Academy LMS <= 4.0.7 - Authenticated (Academy Instructor+) Missing Authorization to Plugin Settings Disclosure
Medium 4.3
CWE-862Fixed in 4.0.8
- ID
- WPSEC-2026-1671
- Plugin
- Academy LMS – WordPress LMS Plugin for Complete eLearning Solution (academy)
- Affected
- all versions before 4.0.8
- Remediation
- Update to 4.0.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-27
- Attack surface
- Academy LMS on WPSec AttackSurface
- Fix released
- Published
Description
The academy plugin for WordPress is vulnerable to Sensitive Information Exposure via the settings REST endpoint in all versions up to, and including, 4.0.7, due to a permission callback that grants access to any user with the 'manage_academy_instructor' capability instead of only site administrators. This makes it possible for authenticated attackers, with Academy Instructor-level access and above, to read the plugin's global settings, including the stored ChatGPT (OpenAI) API key.
References
- https://wpsec.com/vuln/WPSEC-2026-1671/
- https://plugins.svn.wordpress.org/academy/tags/4.0.8/
- https://wordpress.org/plugins/academy/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS