Vulnerabilities / Autoptimize / WPSEC-2026-1673

Autoptimize <= 3.1.16 - Authenticated (Contributor+) Stored Cross-Site Scripting via Google Fonts Optimization

Medium 4.9 CWE-79Fixed in 3.1.17
ID
WPSEC-2026-1673
Plugin
Autoptimize (autoptimize)
Affected
all versions before 3.1.17
Remediation
Update to 3.1.17 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-10-27
Attack surface
Autoptimize on WPSec AttackSurface
Fix released
Published

Description

The Autoptimize plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Google Fonts optimization feature in all versions up to, and including, 3.1.16 due to insufficient output escaping of the font-family string taken from Google Fonts URLs found in the page HTML. That string, which is URL-decoded for Google Fonts API v2 URLs, is placed without escaping into the href attribute of the combined Google Fonts <link> tag. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page. Exploitation requires the Google Fonts option to be set to one of the non-default 'combine and link' or 'combine and preload' modes.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0