Vulnerabilities / Rocket Font / WPSEC-2026-1692

Rocket Font <= 1.2.3 - Unauthenticated Stored Cross-Site Scripting via Plugin Settings

High 7.2 CWE-79Fixed in 2.1.2
ID
WPSEC-2026-1692
Plugin
Rocket Font (rocket-font)
Affected
all versions before 2.1.2
Remediation
Update to 2.1.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-27
Attack surface
Rocket Font on WPSec AttackSurface
Fix released
Published

Description

The rocket-font plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's settings (such as the font color, font size and class/ID selector list options) in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping on the settings page. Combined with the unprotected settings update handler, this makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute when an administrator accesses the plugin's settings page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0