Vulnerabilities / LightBox Block / WPSEC-2026-1716

LightBox Block <= 1.2.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Lightbox Item URLs

Medium 6.4 CWE-79Fixed in 1.2.1
ID
WPSEC-2026-1716
Plugin
All In One Lightbox – show any media in beautiful popups (lightbox-block)
Affected
all versions before 1.2.1
Remediation
Update to 1.2.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
Attack surface
LightBox Block on WPSec AttackSurface
Fix released
Published

Description

The All In One Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the lightbox block's item URL attributes (such as video, audio and image item URLs and iframe sources) in all versions up to, and including, 1.2.0. This is due to insufficient validation of URL schemes before the values are used as link targets opened in the lightbox and as iframe sources, allowing javascript: URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and opens the lightbox item.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0