Vulnerabilities / WP2LEADS | WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden / WPSEC-2026-1718
WP2LEADS | WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden <= 3.5.6 - Authenticated (Subscriber+) SQL Injection via Global Table Search
Medium 6.5
CWE-89Fixed in 3.5.12
- ID
- WPSEC-2026-1718
- Plugin
- WP2LEADS | WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden (wp2leads)
- Affected
- all versions before 3.5.12
- Remediation
- Update to 3.5.12 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weakness
- CWE-89
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- WP2LEADS | WordPress und KlickTipp einfach verbinden – WooCommerce und KlickTipp einfach verbinden on WPSec AttackSurface
- Fix released
- Published
Description
The WP2LEADS plugin for WordPress is vulnerable to SQL Injection via the table, column and order parameters of the global table search and multisearch AJAX actions in all versions up to, and including, 3.5.6. This is due to these values being placed into DESCRIBE and SELECT statements without validation against the database schema or an allowlist, combined with missing capability checks on the handlers. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject SQL and extract sensitive information from the database.
References
- https://wpsec.com/vuln/WPSEC-2026-1718/
- https://plugins.svn.wordpress.org/wp2leads/tags/3.5.12/
- https://wordpress.org/plugins/wp2leads/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS