Vulnerabilities / iChart – Easy Charts and Graphs / WPSEC-2026-1721
iChart – Easy Charts and Graphs <= 2.2.2 - Authenticated (Subscriber+) Sensitive Information Exposure via qcld_ai_get_chart AJAX Action
Medium 4.3
CWE-639Fixed in 2.2.3
- ID
- WPSEC-2026-1721
- Plugin
- iChart – Easy Charts and Graphs (ichart)
- Affected
- all versions before 2.2.3
- Remediation
- Update to 2.2.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- iChart – Easy Charts and Graphs on WPSec AttackSurface
- Fix released
- Published
Description
The iChart plugin for WordPress is vulnerable to Sensitive Information Exposure via the qcld_ai_get_chart AJAX action in all versions up to, and including, 2.2.2. This is due to a missing capability check and no post-type restriction on the user-supplied 'post_id' parameter, with only a nonce check that was exposed to all logged-in users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read chart datasets, prompts and chart type metadata stored on arbitrary posts, including unpublished charts.
References
- https://wpsec.com/vuln/WPSEC-2026-1721/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.3/
- https://wordpress.org/plugins/ichart/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS