iChart – Easy Charts and Graphs <= 2.2.2 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary Post Modification via 'edit_post_id' Parameter
- ID
- WPSEC-2026-1723
- Plugin
- iChart – Easy Charts and Graphs (ichart)
- Affected
- all versions before 2.2.3
- Remediation
- Update to 2.2.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- iChart – Easy Charts and Graphs on WPSec AttackSurface
- Fix released
- Published
Description
The iChart plugin for WordPress is vulnerable to Insecure Direct Object Reference via the qcld_ai_save_chart AJAX action in all versions up to, and including, 2.2.2. This is due to a missing capability check and missing validation on the user-controlled 'edit_post_id' parameter, which was passed directly to wp_update_post() and update_post_meta() with only a nonce check, and that nonce was exposed to all logged-in users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create chart posts, overwrite the title of arbitrary posts of any post type, and write chart metadata to them.
References
- https://wpsec.com/vuln/WPSEC-2026-1723/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.3/
- https://wordpress.org/plugins/ichart/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS