Vulnerabilities / Co-Authors Plus / WPSEC-2026-1746

Co-Authors Plus <= 4.1.2 - Authenticated (Contributor+) Missing Authorization to Post Co-Author Modification via REST API and tax_input

Medium 4.3 CWE-862Fixed in 4.1.3
ID
WPSEC-2026-1746
Plugin
Co-Authors Plus (co-authors-plus)
Affected
all versions before 4.1.3
Remediation
Update to 4.1.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
Attack surface
Co-Authors Plus on WPSec AttackSurface
Fix released
Published

Description

The Co-Authors Plus plugin for WordPress is vulnerable to unauthorized modification of data via the REST API 'coauthors' parameter and the 'tax_input' post field in all versions up to, and including, 4.1.2, due to the author taxonomy using WordPress's default assign_terms capability (edit_posts) instead of the plugin's set-authors check (edit_others_posts by default). This makes it possible for authenticated attackers with Contributor-level access and above, who are not permitted to set authors, to change or clear the co-authors (bylines) of posts they can edit, for example crediting their own posts to other users.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0