Vulnerabilities / Co-Authors Plus / WPSEC-2026-1747
Co-Authors Plus <= 4.1.2 - Authenticated (Subscriber+) Improper Authorization to Co-Authored Post Editing
Medium 4.2
CWE-863Fixed in 4.1.3
- ID
- WPSEC-2026-1747
- Plugin
- Co-Authors Plus (co-authors-plus)
- Affected
- all versions before 4.1.3
- Remediation
- Update to 4.1.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-863
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-27
- Attack surface
- Co-Authors Plus on WPSec AttackSurface
- Fix released
- Published
Description
The Co-Authors Plus plugin for WordPress is vulnerable to improper authorization via the co-author capability filter in all versions up to, and including, 4.1.2, due to the user_has_cap filter granting the edit_others_posts capability to any user credited as a co-author of a post, whatever their own role allows. This makes it possible for authenticated attackers with Subscriber-level access and above who are credited as a co-author on a post (for example a user demoted after being credited) to view and edit draft and pending posts their role would not otherwise let them edit.
References
- https://wpsec.com/vuln/WPSEC-2026-1747/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.1.3/
- https://wordpress.org/plugins/co-authors-plus/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS