Vulnerabilities / Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors / WPSEC-2026-1751
Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors <= 4.17.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Authors List 'layout' Shortcode Attribute
Medium 6.4
CWE-79Fixed in 4.18.0
- ID
- WPSEC-2026-1751
- Plugin
- Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors (publishpress-authors)
- Affected
- all versions before 4.18.0
- Remediation
- Update to 4.18.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors on WPSec AttackSurface
- Fix released
- Published
Description
The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'layout' attribute used by the authors list rendering in all versions up to, and including, 4.17.0 due to the value being placed into an inline style block without sanitization. This makes it possible for authenticated attackers, with contributor-level access and above, to break out of the style element and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1751/
- https://plugins.svn.wordpress.org/publishpress-authors/tags/4.18.0/
- https://wordpress.org/plugins/publishpress-authors/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS