Vulnerabilities / WP GPX Maps / WPSEC-2026-1767
WP GPX Maps <= 1.7.11 - Unauthenticated Reflected Cross-Site Scripting via 'nggalleries' and 'ngimages' Parameters
Medium 6.1
CWE-79Fixed in 1.8.00
- ID
- WPSEC-2026-1767
- Plugin
- WP GPX Maps (wp-gpx-maps)
- Affected
- all versions before 1.8.00
- Remediation
- Update to 1.8.00 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- WP GPX Maps on WPSec AttackSurface
- Fix released
- Published
Description
The WP GPX Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'nggalleries' and 'ngimages' parameters in all versions up to, and including, 1.7.11. This is due to shortcode parameters falling back to values from the page URL query string and being output inside a JavaScript array literal with only esc_js(), which does not prevent injection of raw JavaScript expressions. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute when a user clicks a crafted link to a page containing the [sgpx] shortcode.
References
- https://wpsec.com/vuln/WPSEC-2026-1767/
- https://plugins.svn.wordpress.org/wp-gpx-maps/tags/1.8.00/
- https://wordpress.org/plugins/wp-gpx-maps/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS