Vulnerabilities / WP GPX Maps / WPSEC-2026-1770
WP GPX Maps <= 1.7.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'nggalleries' and 'ngimages' Shortcode Attributes
Medium 6.4
CWE-79Fixed in 1.8.00
- ID
- WPSEC-2026-1770
- Plugin
- WP GPX Maps (wp-gpx-maps)
- Affected
- all versions before 1.8.00
- Remediation
- Update to 1.8.00 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- WP GPX Maps on WPSec AttackSurface
- Fix released
- Published
Description
The WP GPX Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'nggalleries' and 'ngimages' attributes of the [sgpx] shortcode in all versions up to, and including, 1.7.11. This is due to insufficient input sanitization, as the values are placed inside a JavaScript array literal wrapped only in esc_js(), which does not prevent raw JavaScript expressions. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1770/
- https://plugins.svn.wordpress.org/wp-gpx-maps/tags/1.8.00/
- https://wordpress.org/plugins/wp-gpx-maps/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS