Vulnerabilities / AI Engine / WPSEC-2026-1803

AI Engine <= 3.8.7 - Authenticated (Editor+) Sensitive Information Exposure via Log Endpoints

Low 3.3 CWE-284Fixed in 3.8.8
ID
WPSEC-2026-1803
Plugin
AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini (ai-engine)
Affected
all versions before 3.8.8
Remediation
Update to 3.8.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-284
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
Attack surface
AI Engine on WPSec AttackSurface
Fix released
Published

Description

The AI Engine plugin for WordPress is vulnerable to Sensitive Information Exposure via the /mwai/v1/get_logs and /mwai/v1/clear_logs REST endpoints in all versions up to, and including, 3.8.7, due to the endpoints checking can_access_features() (Editor or Administrator) instead of the settings capability (manage_options). This makes it possible for authenticated attackers, with Editor-level access and above, to read the plugin's debug log, which can contain chat messages and request details from other users, and to delete it. The log is only written when Dev Tools and server debug mode are enabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0