Vulnerabilities / EasyJobs / WPSEC-2026-1828
EasyJobs <= 2.8.4 - Unauthenticated Stored Cross-Site Scripting via Malicious PDF Resume
Medium 6.1
CWE-79Fixed in 2.8.5
- ID
- WPSEC-2026-1828
- Plugin
- easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution (easyjobs)
- Affected
- from 2.8.1 before 2.8.5
- Remediation
- Update to 2.8.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-28
- Attack surface
- EasyJobs on WPSec AttackSurface
- Fix released
- Published
Description
The easy.jobs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via candidate resume PDFs in all versions up to, and including, 2.8.4, due to the candidate details screen rendering resumes with a bundled copy of pdf.js 3.11.174, which is affected by CVE-2024-4367, opened with default options (font evaluation enabled). This makes it possible for unauthenticated attackers who apply to a job with a crafted PDF resume to execute arbitrary scripts in an administrator's browser when the administrator views the candidate's resume in wp-admin.
References
- https://wpsec.com/vuln/WPSEC-2026-1828/
- https://plugins.svn.wordpress.org/easyjobs/tags/2.8.5/
- https://wordpress.org/plugins/easyjobs/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS