Post Grid Gutenberg Blocks <= 5.1.1 - Authenticated (Editor+) Stored Cross-Site Scripting via Site Dark Logo

Medium 5.5 CWE-79Fixed in 5.1.2
ID
WPSEC-2026-1859
Plugin
Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX (ultimate-post)
Affected
from 3.1.9 before 5.1.2
Remediation
Update to 5.1.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
Attack surface
Post Grid Gutenberg Blocks on WPSec AttackSurface
Fix released
Published

Description

The Post Grid Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the site dark logo setting in all versions up to, and including, 5.1.1, due to the /ultp/v2/init_site_dark_logo/ REST endpoint only requiring the edit_others_posts capability and storing the supplied logo URL without sanitization, and to that value being printed without escaping inside an inline style element on every page using the dark mode. This makes it possible for authenticated attackers, with Editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0