Vulnerabilities / GiveWP / WPSEC-2026-1871

GiveWP <= 4.19.0.2 - Cross-Site Request Forgery to Multiple Administrative Actions

Medium 4.3 CWE-352Fixed in 4.19.1
ID
WPSEC-2026-1871
Plugin
GiveWP – Donation Plugin and Fundraising Platform (give)
Affected
from 2.9.0 before 4.19.1
Remediation
Update to 4.19.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
Attack surface
GiveWP on WPSec AttackSurface
Fix released
Published

Description

The GiveWP plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions 2.9.0 up to, and including, 4.19.0.2, due to missing nonce validation on several administrative request handlers: the PayPal Commerce onboarding AJAX actions (give_paypal_commerce_get_partner_url and give_paypal_commerce_user_on_boarded), the Stripe statement descriptor update and default Stripe account AJAX actions, the manual migration request (give-run-migration / give-clear-update), and the usage tracking opt-in action. These handlers checked only the manage_give_settings capability. This makes it possible for unauthenticated attackers to make the plugin change its PayPal Commerce account country and partner onboarding details, change the statement descriptor of a connected Stripe account or the default Stripe account, re-run or reset database migrations, or turn on usage tracking, via a forged request, provided they can trick a site administrator into performing an action such as clicking a link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0