Vulnerabilities / bbPress / WPSEC-2026-1880

bbPress <= 2.6.20 - Unauthenticated Sensitive Information Exposure via BuddyPress Group Forums

Medium 5.3 CWE-200Fixed in 2.6.21
ID
WPSEC-2026-1880
Plugin
bbPress (bbpress)
Affected
all versions before 2.6.21
Remediation
Update to 2.6.21 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-28
Attack surface
bbPress on WPSec AttackSurface
Fix released
Published

Description

The bbPress plugin for WordPress is vulnerable to Sensitive Information Exposure via BuddyPress group forums in all versions up to, and including, 2.6.20, due to group forum read checks ignoring BuddyPress community visibility. Public group forums were treated as readable by everyone even when the BuddyPress community was set to Members Only. This makes it possible for unauthenticated attackers to read group forums, topics and replies that the site restricts to logged-in community members.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0