Vulnerabilities / Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) / WPSEC-2026-1894
Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) <= 4.8.6 - Cross-Site Request Forgery to Voucher Template Deletion
Medium 4.3
CWE-352Fixed in 4.9.0
- ID
- WPSEC-2026-1894
- Plugin
- Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) (gift-voucher)
- Affected
- all versions before 4.9.0
- Remediation
- Update to 4.9.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) on WPSec AttackSurface
- Fix released
- Published
Description
The Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) plugin for WordPress is vulnerable to Cross-Site Request Forgery via the 'bulk-delete' action of the legacy Voucher Templates screen in all versions up to, and including, 4.8.6, due to missing nonce validation in WPGV_Voucher_Template::process_bulk_action(). This makes it possible for unauthenticated attackers to delete voucher templates, including templates still used by existing orders, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1894/
- https://plugins.svn.wordpress.org/gift-voucher/tags/4.9.0/
- https://wordpress.org/plugins/gift-voucher/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS