WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell <= 3.13.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gutenberg CSS

Medium 6.4 CWE-79Fixed in 3.13.6
ID
WPSEC-2026-1900
Plugin
WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell (wpfunnels)
Affected
all versions before 3.13.6
Remediation
Update to 3.13.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell on WPSec AttackSurface
Fix released
Published

Description

The WPFunnels plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Gutenberg CSS REST routes in all versions up to, and including, 3.13.5 due to the routes only checking the edit_posts capability rather than permission to edit the targeted post, and insufficient sanitization that decoded HTML entities after stripping tags, allowing an encoded closing style tag to survive and be output raw inside a style block. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts into any post that will execute whenever a user accesses the affected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0