Vulnerabilities / EventPrime / WPSEC-2026-1913

EventPrime <= 4.3.6.0 - Unauthenticated Sensitive Information Exposure via Public 'pending' Post Status

Medium 5.3 CWE-200Fixed in 4.3.6.1
ID
WPSEC-2026-1913
Plugin
EventPrime – Events Calendar, Bookings, Tickets & AI (eventprime-event-calendar-management)
Affected
all versions before 4.3.6.1
Remediation
Update to 4.3.6.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
Attack surface
EventPrime on WPSec AttackSurface
Fix released
Published

Description

The EventPrime plugin for WordPress is vulnerable to Sensitive Information Exposure via its booking post status registration in all versions up to, and including, 4.3.6.0, due to the plugin re-registering the global 'pending' post status as public, which overrides WordPress's built-in Pending Review status. This makes it possible for unauthenticated attackers to view posts, pages and other content awaiting review that should not yet be publicly accessible.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0