Vulnerabilities / Responder / WPSEC-2026-1928

Responder <= 4.4.4 - Authenticated (Contributor+) Sensitive Information Exposure via Responder Debug Log Entries

Low 3.1 CWE-200Fixed in 4.4.5
ID
WPSEC-2026-1928
Plugin
Responder (responder)
Affected
all versions before 4.4.5
Remediation
Update to 4.4.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
Responder on WPSec AttackSurface
Fix released
Published

Description

The Responder plugin for WordPress is vulnerable to Sensitive Information Exposure via the Responder Debug log (responder_debug custom post type) in all versions up to, and including, 4.4.4 due to the post type being registered with the default 'post' capability type and meta-capability mapping instead of administrator-only capabilities. This makes it possible for authenticated attackers, with Contributor-level access and above, to list debug entries whose titles reveal submitted lead identities, and for Editor-level users to open entries containing leads' names, email addresses, phone numbers and API responses. Exploitation requires the plugin's debug logging to be enabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0