Vulnerabilities / Email Templates / WPSEC-2026-1935

Email Templates <= 1.5.14 - Unauthenticated Sensitive Information Exposure via WooCommerce Email Preview

Medium 5.3 CWE-862Fixed in 1.5.15
ID
WPSEC-2026-1935
Plugin
Email Templates Customizer and Designer for WordPress and WooCommerce (email-templates)
Affected
from 1.4 before 1.5.15
Remediation
Update to 1.5.15 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
Attack surface
Email Templates on WPSec AttackSurface
Fix released
Published

Description

The Email Templates Customizer and Designer for WordPress and WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the WooCommerce email preview in all versions up to, and including, 1.5.14, due to a missing capability check on the front-end preview handler and on the loading of real orders by the user-supplied preview_order ID, combined with a missing capability check on the admin_init redirect that hands out the 'open-email-template' preview nonce. This makes it possible for unauthenticated attackers to obtain a valid logged-out nonce and render WooCommerce email previews for arbitrary order IDs, exposing other customers' order data such as names, billing and shipping addresses, email addresses and purchased items, on sites where WooCommerce is active.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0