Ad Inserter – Ad Manager & AdSense Ads <= 2.8.19 - Reflected Cross-Site Scripting via Request URI in Debugging Tools and {url} Tag
- ID
- WPSEC-2026-1943
- Plugin
- Ad Inserter – Ad Manager & AdSense Ads (ad-inserter)
- Affected
- all versions before 2.8.20
- Remediation
- Update to 2.8.20 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Ad Inserter – Ad Manager & AdSense Ads on WPSec AttackSurface
- Fix released
- Published
Description
The Ad Inserter plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the request URI in all versions up to, and including, 2.8.19 due to insufficient output escaping. URLs built from the current request with remove_query_arg()/add_query_arg(), which return decoded query parameter names, were printed without escaping in the links of the front-end Debugging tools block and widget, and were substituted unescaped for the {url} tag in block code. The Debugging tools block also rendered for any visitor. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into clicking a crafted link.
References
- https://wpsec.com/vuln/WPSEC-2026-1943/
- https://plugins.svn.wordpress.org/ad-inserter/tags/2.8.20/
- https://wordpress.org/plugins/ad-inserter/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS