Vulnerabilities / Ad Inserter – Ad Manager & AdSense Ads / WPSEC-2026-1944
Ad Inserter – Ad Manager & AdSense Ads <= 2.8.19 - Authenticated (Contributor+) Stored Cross-Site Scripting via adinserter Shortcode Attribute Placeholders
Medium 4.9
CWE-79Fixed in 2.8.20
- ID
- WPSEC-2026-1944
- Plugin
- Ad Inserter – Ad Manager & AdSense Ads (ad-inserter)
- Affected
- all versions before 2.8.20
- Remediation
- Update to 2.8.20 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Ad Inserter – Ad Manager & AdSense Ads on WPSec AttackSurface
- Fix released
- Published
Description
The Ad Inserter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the attributes of the 'adinserter' shortcode in all versions up to, and including, 2.8.19. This is due to insufficient output escaping: replace_ai_tags() substitutes shortcode attribute values directly into the {#name#} placeholders of the block code. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute whenever a user accesses an injected page, on sites where a block's code uses such placeholders.
References
- https://wpsec.com/vuln/WPSEC-2026-1944/
- https://plugins.svn.wordpress.org/ad-inserter/tags/2.8.20/
- https://wordpress.org/plugins/ad-inserter/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS