Vulnerabilities / User Frontend / WPSEC-2026-1946
User Frontend <= 4.3.13 - Unauthenticated Stored Cross-Site Scripting via Category Name
Medium 5.4
CWE-79Fixed in 4.3.14
- ID
- WPSEC-2026-1946
- Plugin
- User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (wp-user-frontend)
- Affected
- all versions before 4.3.14
- Remediation
- Update to 4.3.14 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- User Frontend on WPSec AttackSurface
- Fix released
- Published
Description
The User Frontend plugin for WordPress is vulnerable to Stored Cross-Site Scripting via taxonomy term names in all versions up to, and including, 4.3.13 due to term names being output without escaping in the Vue-mounted admin form builder, allowing both HTML and Vue template injection. This makes it possible for unauthenticated attackers, where a frontend form lets guests submit new category terms, to inject arbitrary web scripts that execute when an administrator opens that form in the form builder.
References
- https://wpsec.com/vuln/WPSEC-2026-1946/
- https://plugins.svn.wordpress.org/wp-user-frontend/tags/4.3.14/
- https://wordpress.org/plugins/wp-user-frontend/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS