Vulnerabilities / User Frontend / WPSEC-2026-1950
User Frontend <= 4.3.13 - Reflected Cross-Site Scripting via Category Field
Medium 6.1
CWE-79Fixed in 4.3.14
- ID
- WPSEC-2026-1950
- Plugin
- User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (wp-user-frontend)
- Affected
- all versions before 4.3.14
- Remediation
- Update to 4.3.14 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- User Frontend on WPSec AttackSurface
- Fix released
- Published
Description
The User Frontend plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the category field of frontend forms in all versions up to, and including, 4.3.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a crafted link.
References
- https://wpsec.com/vuln/WPSEC-2026-1950/
- https://plugins.svn.wordpress.org/wp-user-frontend/tags/4.3.14/
- https://wordpress.org/plugins/wp-user-frontend/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS