Vulnerabilities / Premium Packages / WPSEC-2026-1959

Premium Packages <= 7.3.0 - Authenticated (Subscriber+) Insecure Direct Object Reference to Guest Order Takeover

Medium 5.4 CWE-639Fixed in 7.3.1
ID
WPSEC-2026-1959
Plugin
Premium Packages – Sell Digital Products Securely (wpdm-premium-packages)
Affected
all versions before 7.3.1
Remediation
Update to 7.3.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-639
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
Premium Packages on WPSec AttackSurface
Fix released
Published

Description

The Premium Packages plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 7.3.0 due to missing ownership validation when linking guest orders to user accounts through the 'resolveorder' AJAX action, the 'invoice' field on the login and registration forms, and the order view page. This makes it possible for authenticated attackers, with subscriber-level access and above, to link any unassigned guest order to their own account using only its order ID, gaining access to the guest buyer's purchased downloads and billing information. Where user registration is enabled, this can be performed by unauthenticated visitors through the signup form.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0