Vulnerabilities / Events Made Easy / WPSEC-2026-1976

Events Made Easy <= 3.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Location Map Shortcode Attributes

Medium 6.4 CWE-79Fixed in 3.3.2
ID
WPSEC-2026-1976
Plugin
Events Made Easy (events-made-easy)
Affected
all versions before 3.3.2
Remediation
Update to 3.3.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
Events Made Easy on WPSec AttackSurface
Fix released
Published

Description

The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width', 'height' and 'zoom' attributes of the plugin's location map shortcodes ([eme_location_map], [eme_locations_map], [locations_map], [display_single_location]) in all versions up to, and including, 3.3.1. This is due to insufficient input sanitization and output escaping: the attribute values pass only through sanitize_text_field(), which leaves single quotes intact, and are then placed inside single-quoted HTML attributes (the map container's style attribute and data-zoom_factor). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0