Vulnerabilities / Media Library Assistant / WPSEC-2026-1981
Media Library Assistant <= 3.43 - Authenticated (Contributor+) Sensitive Information Exposure via 'parent:post_password' Substitution Parameter
Medium 4.3
CWE-200Fixed in 3.44
- ID
- WPSEC-2026-1981
- Plugin
- Media Library Assistant (media-library-assistant)
- Affected
- all versions before 3.44
- Remediation
- Update to 3.44 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- Media Library Assistant on WPSec AttackSurface
- Fix released
- Published
Description
The Media Library Assistant plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'parent:' field-level substitution parameter of its shortcodes in all versions up to, and including, 3.43, due to mla_expand_field_level_parameters() returning any property of the parent post, including post_password. This makes it possible for authenticated attackers with contributor-level access and above to reveal the passwords of password-protected posts and pages that have attached media items.
References
- https://wpsec.com/vuln/WPSEC-2026-1981/
- https://plugins.svn.wordpress.org/media-library-assistant/tags/3.44/
- https://wordpress.org/plugins/media-library-assistant/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS