Media Library Assistant <= 3.43 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
- ID
- WPSEC-2026-1983
- Plugin
- Media Library Assistant (media-library-assistant)
- Affected
- all versions before 3.44
- Remediation
- Update to 3.44 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- Media Library Assistant on WPSec AttackSurface
- Fix released
- Published
Description
The Media Library Assistant plugin for WordPress is vulnerable to Stored Cross-Site Scripting via attributes of its shortcodes, including mla_gallery, mla_custom_list, mla_archive_list and mla_term_list, in all versions up to, and including, 3.43. This is due to insufficient input sanitization and output escaping of values such as the 'unit' attribute, 'mla_nolink_text' (sanitized before template substitution rather than after), meta values, labels and term names. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1983/
- https://plugins.svn.wordpress.org/media-library-assistant/tags/3.44/
- https://wordpress.org/plugins/media-library-assistant/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS