Vulnerabilities / Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder / WPSEC-2026-1986
Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder <= 2.5.64 - Authenticated (Contributor+) Stored Cross-Site Scripting via Typing Effect Module Strings
Medium 6.4
CWE-79Fixed in 2.5.65
- ID
- WPSEC-2026-1986
- Plugin
- Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder (supreme-modules-for-divi)
- Affected
- all versions before 2.5.65
- Remediation
- Update to 2.5.65 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder on WPSec AttackSurface
- Fix released
- Published
Description
The Supreme Modules Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Typing Effect module's 'typing_effect' strings in all versions up to, and including, 2.5.64, due to the front-end script passing the stored strings to Typed.js with contentType set to 'html', which writes them into the page with innerHTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1986/
- https://plugins.svn.wordpress.org/supreme-modules-for-divi/tags/2.5.65/
- https://wordpress.org/plugins/supreme-modules-for-divi/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS