Vulnerabilities / Burst Statistics / WPSEC-2026-2011

Burst Statistics <= 3.7.3 - Unauthenticated Security Plugin Bypass via REST API Optimizer

Medium 4.8 CWE-693Fixed in 3.7.4
ID
WPSEC-2026-2011
Plugin
Burst Statistics – Simple WordPress Analytics (Google Analytics Alternative) (burst-statistics)
Affected
all versions before 3.7.4
Remediation
Update to 3.7.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-693
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-10-30
Attack surface
Burst Statistics on WPSec AttackSurface
Fix released
Published

Description

The Burst Statistics plugin for WordPress is vulnerable to a protection mechanism bypass via the REST API Optimizer must-use plugin in all versions up to, and including, 3.7.3, due to the optimizer treating any request whose URL path contains '/wp-json/burst/v1' as a Burst REST request, regardless of the script that handles it. Because of this, requests to other entry points that carry the route as extra path info, such as /wp-login.php/wp-json/burst/v1/x or /xmlrpc.php/wp-json/burst/v1/x on servers that pass extra path information to PHP scripts, such as Apache, also have most other active plugins unloaded (all except Burst's own and a short keep list). This makes it possible for unauthenticated attackers to run login and XML-RPC requests without the security plugins that would normally protect them, such as two-factor authentication, login attempt limiting or XML-RPC blocking. The optimizer is installed automatically when the mu-plugins directory is writable, and the impact depends on which security plugins the site relies on.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0