Import and export users and customers <= 2.5.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via [export-users] Shortcode 'from' Attribute

Medium 6.4 CWE-79Fixed in 2.5.10
ID
WPSEC-2026-2030
Plugin
Import and export users and customers (import-users-from-csv-with-meta)
Affected
all versions before 2.5.10
Remediation
Update to 2.5.10 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
Attack surface
Import and export users and customers on WPSec AttackSurface
Fix released
Published

Description

The Import and export users and customers plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'from' attribute of the [export-users] shortcode in all versions up to, and including, 2.5.9, due to a date check that only looks for a date anywhere in the value and missing output escaping when the value is printed into a hidden form field. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user allowed to create users, such as an administrator, accesses or previews the injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0