Vulnerabilities / SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster / WPSEC-2026-2035
SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster <= 2.8.0 - Missing Authorization to Authenticated (Subscriber+) WooCommerce Plugin Installation and Activation
Medium 4.3
CWE-862Fixed in 2.8.1
- ID
- WPSEC-2026-2035
- Plugin
- SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster (sellkit)
- Affected
- all versions before 2.8.1
- Remediation
- Update to 2.8.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster on WPSec AttackSurface
- Fix released
- Published
Description
The SellKit plugin for WordPress is vulnerable to unauthorized plugin installation and activation via the 'sellkit_install_woocommerce_plugin_by_notice' AJAX action in all versions up to, and including, 2.8.0. This is due to a missing capability check on the installer() function, which verifies only the 'sellkit_admin' nonce. That nonce is printed on every wp-admin page for any logged-in user. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate the WooCommerce plugin on the site.
References
- https://wpsec.com/vuln/WPSEC-2026-2035/
- https://plugins.svn.wordpress.org/sellkit/tags/2.8.1/
- https://wordpress.org/plugins/sellkit/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS